Перейти к содержимому


Ads
Фотография
* * * * * 1 Голосов

Какой дистрибутив выбрать новичку


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 660

#61 Net_Rus

Net_Rus

    Angel

  • Почетный житель
  • 540 сообщений

Отправлено 30.01.2008, 13:20

Ну вот это вот не надо.


А их так понимаю теперь не надо вписывать?

#62 Net_Rus

Net_Rus

    Angel

  • Почетный житель
  • 540 сообщений

Отправлено 30.01.2008, 23:53

Люди выручайте не как не получается создать подключение к интре в opensuse? вроде создаю провайдера и сюравно не работает? может кто нить подкинет мануальчик или объяснит? может kinternet нужен новенький?

Сообщение отредактировал Raly_Sport: 31.01.2008, 00:21


#63 Net_Rus

Net_Rus

    Angel

  • Почетный житель
  • 540 сообщений

Отправлено 31.01.2008, 15:35

Помогите найти дрова для Attansic® L1 Gigabit Ethernet Adapter под opensuse

#64 Net_Rus

Net_Rus

    Angel

  • Почетный житель
  • 540 сообщений

Отправлено 31.01.2008, 16:41

Помогите найти дрова для Attansic® L1 Gigabit Ethernet Adapter под opensuse 10.2


вот я нашёл дрова atl1-2.0.6.1-linux-2.6.19-standalone.tar а как поставить незнаю?

#65 Net_Rus

Net_Rus

    Angel

  • Почетный житель
  • 540 сообщений

Отправлено 31.01.2008, 17:20

вот есть редми ну я что то в нём неразберусь

Linux* Base Driver for the Attansic® L1 Gigabit Ethernet Adapter
==========================================================================

Contents
========

- In This Release
- Building and Installation
- Command Line Parameters
- Additional Configurations
- Known Issues
- Support

In This Release
===============

This file describes the Linux* Base Driver for the Attansic® L1 Gigabit
Ethernet Adapter, version 1.0.x. This driver supports the 2.4.x and 2.6.x kernels.

This driver is only supported as a loadable module at this time. Attansic is not
supplying patches against the kernel source to allow for static linking of
the driver. For questions related to hardware requirements, refer to the
documentation supplied with your Attansic® adapter. All hardware
requirements listed apply to use with Linux.

Building and Installation
=========================

To build a binary RPM* package of this driver, run 'rpmbuild -tb
<filename.tar.gz>'. Replace <filename.tar.gz> with the specific filename of
the driver.

NOTE: For the build to work properly, the currently running kernel MUST match
the version and configuration of the installed kernel sources. If you
have just recompiled the kernel reboot the system now.

RPM functionality has only been tested in Red Hat distributions.

1. Move the base driver tar file to the directory of your choice. For example,
use /home/username/atl1 or /usr/local/src/atl1.

2. Untar/unzip archive:

tar zxf atl1-x.x.x.tar.gz

3. Change to the driver src directory:

cd atl1-x.x.x/src/

4. Compile the driver module:

make install

The binary will be installed as:

/lib/modules/<KERNEL VERSION>/kernel/drivers/net/atl1.[k]o

The install locations listed above are the default locations. They might
not be correct for certain Linux distributions. For more information,
see the ldistrib.txt file included in the driver tar.

5. Install the module:

insmod atl1 <parameter>=<value>

6. Assign an IP address to the interface by entering the following, where
x is the interface number:

ifconfig ethx <IP_address>

7. Verify that the interface works. Enter the following, where <IP_address>
is the IP address for another machine on the same subnet as the interface
that is being tested:

ping <IP_address>

Command Line Parameters
=======================

If the driver is built as a module, the following optional parameters are
used by entering them on the command line with the modprobe or insmod command
using this syntax:

modprobe atl1 [<option>=<VAL1>,<VAL2>,...]

insmod atl1 [<option>=<VAL1>,<VAL2>,...]

For example, with two L001 PCIE adapters, entering:

insmod atl1 TxDescriptors=80,128

loads the atl1 driver with 80 TX descriptors for the first adapter and 128 TX
descriptors for the second adapter.

The default value for each parameter is generally the recommended setting,
unless otherwise noted.

NOTES: A descriptor describes a data buffer and attributes related to the
data buffer. This information is accessed by the hardware.

MediaType
Valid Range: 0-5
0 - auto-negotiate at all supported speeds
1 - only link at 1000Mbps Full Duplex
2 - only link at 100Mbps Full Duplex
3 - only link at 100Mbps Half Duplex
4 - only link at 10Mbps Full Duplex
5 - only link at 10Mbps Half Duplex
Default Value: 0
MediaType forces the line speed/duplex to the specified value in
megabits per second(Mbps). If this parameter is not specified or is set
to 0 and the link partner is set to auto-negotiate, the board will
auto-detect the correct speed.

IntModTimer
Valid Range: 50-65000
Default Value: 100
This value represents the minmum interval between interrupts controller
generated.

RxDescriptors
Valid Range: 128-2047

Default Value: 256
This value is the number of RFD/RRD descriptors allocated by the driver.
Increasing this value allows the driver to buffer more incoming packets.
A receive buffer is also allocated for each descriptor and can be either
2048, 4096, or 8192 bytes, depending on the MTU setting.
The maximum MTU size is 8192.

NOTE: MTU designates the frame size. It only needs to be set for Jumbo
Frames.
NOTE: Depending on the available system resources, the request for a
higher number of receive descriptors may be denied. In this case,
use a lower number.

TxDescriptors
Valid Range: 64-1023

Default Value: 512
This value is the number of transmit descriptors allocated by the driver.
Increasing this value allows the driver to queue more transmits.

NOTE: Depending on the available system resources, the request for a
higher number of transmit descriptors may be denied. In this case,
use a lower number.

FlashVendor
Valid Range: 0-2

Default Value: 0
This value standards on vendor of spi flash used by the adapter.
0 for Atmel, 1 for SST, 2 for ST


Additional Configurations
=========================

Configuring the Driver on Different Distributions
-------------------------------------------------

Configuring a network driver to load properly when the system is started is
distribution dependent. Typically, the configuration process involves adding
an alias line to /etc/modules.conf as well as editing other system startup
scripts and/or configuration files. Many popular Linux distributions ship
with tools to make these changes for you. To learn the proper way to
configure a network device for your system, refer to your distribution
documentation. If during this process you are asked for the driver or module
name, the name for the Linux Base Driver for the Attansic L1 is atl1

As an example, if you install the atl1 driver for two L1 adapters
(eth0 and eth1) and set the speed and duplex to 10full and 100half, add the
following to modules.conf:

alias eth0 atl1
alias eth1 atl1
options atl1 Speed=10,100 Duplex=2,1

Viewing Link Messages
---------------------

Link messages will not be displayed to the console if the distribution is
restricting system messages. In order to see network driver link messages
on your console, set dmesg to eight by entering the following:

dmesg -n 8

NOTE: This setting is not saved across reboots.

Jumbo Frames
------------

The driver supports Jumbo Frames . Jumbo Frames support is enabled by
changing the MTU to a value larger than the default of 1500. Use the
ifconfig command to increase the MTU size. For example:

ifconfig eth<x> mtu 3000 up

NOTE: This setting is not saved across reboots. The setting change can be
made permanent by adding:

MTU=3000

to the file /etc/sysconfig/network-scripts/ifcfg-eth<x>, with Red Hat
distributions, for example. Other distributions may store this setting in a
different location.

NOTE: MTU designates the frame size. To enable Jumbo Frames, increase the MTU
size on the interface beyond 1500.


Known Issues
============

NOTE: For distribution-specific information, see the ldistrib.txt file
included in the driver tar.

Driver Compilation
------------------

When trying to compile the driver by running make install, the following
error may occur:

"Linux kernel source not configured - missing version.h"

To solve this issue, create the version.h file by going to the Linux source
tree and entering:

make include/linux/version.h.

Jumbo Frames System Requirement
-------------------------------

Memory allocation failures have been observed on Linux systems with 64 MB
of RAM or less that are running Jumbo Frames. If you are using Jumbo
Frames, your system may require more than the advertised minimum
requirement of 64 MB of system memory.

Performance Degradation with Jumbo Frames
-----------------------------------------

Degradation in throughput performance may be observed in some Jumbo frames
environments. If this is observed, increasing the application's socket buffer
size and/or increasing the /proc/sys/net/ipv4/tcp_*mem entry values may help.
See the specific application manual and /usr/src/linux*/Documentation/
networking/ip-sysctl.txt for more details.


Support
=======

For general information, go to the Attansic support website at:

http://support.attansic.com

If an issue is identified with the released source code on the supported
kernel with a supported adapter, email the specific information related to
the issue to xiong_huang@attansic.com

License
=======

This software program is released under the terms of a license agreement
between you ('Licensee') and Attansic. Do not use or load this software or any
associated materials (collectively, the 'Software') until you have carefully
read the full terms and conditions of the LICENSE located in this software
package. By loading or using the Software, you agree to the terms of this
Agreement. If you do not agree with the terms of this Agreement, do not
install or use the Software.

* Other names and brands may be claimed as the property of others.

#66 MAVERICK

MAVERICK

    Canon. You Can!

  • Почетный житель
  • 637 сообщений

Отправлено 07.02.2008, 15:47

UBUNTU 7.04 не получается загрузиться в Live CD при загрузке вырубается монитор в режим ожидания, что такое? загружается только в безопасном графическом режиме, чтобы это значило? :dntknw:
Развожу длинноязыкастых БарсеГов!))

#67 Zerocul

Zerocul

    на все кнопки мастер

  • Модератор
  • 9 776 сообщений

Отправлено 07.02.2008, 17:17

acpi=off скорее всего. Или в биосе на время установки выруби это
В черном-черном лесу, на берегу черного-черного озера, на черной-черной полянке сидел черный-черный человек и жег автомобильные покрышки

Воинствующий пешеход на K2 Le Mans 80 / GT Avalanche ELITE / K2 F.I.T. Ice


#68 MAVERICK

MAVERICK

    Canon. You Can!

  • Почетный житель
  • 637 сообщений

Отправлено 07.02.2008, 17:57

acpi=off скорее всего. Или в биосе на время установки выруби это

В биосе только что пробовал выключать всё равно она не загразилась...
Развожу длинноязыкастых БарсеГов!))

#69 BloodyEagle

BloodyEagle

    Злобная Сволочь

  • Почетный житель
  • 900 сообщений

Отправлено 07.02.2008, 20:43

А мне проще всего всетаки показалась ASP Linux (Fedora), или просто я к ней привык.... Установив Убунту, так и не смог отключить автостарт иксов, не оказалось файла inittab как в федоре, а после установки дров видюхи вообще иксы слетели, поэтому снова поставил ASP

#70 Saturn

Saturn

    Новосел

  • Житель
  • 87 сообщений

Отправлено 19.02.2008, 14:23

кто нибудь может записать MOPS 6 или Slackware ? или ссылочку для осла дайте.
По-настоящему свободен тот, кто свободен от своих мыслей...

#71 Zerocul

Zerocul

    на все кнопки мастер

  • Модератор
  • 9 776 сообщений

Отправлено 19.02.2008, 14:25

Я могу и то и другое.
В черном-черном лесу, на берегу черного-черного озера, на черной-черной полянке сидел черный-черный человек и жег автомобильные покрышки

Воинствующий пешеход на K2 Le Mans 80 / GT Avalanche ELITE / K2 F.I.T. Ice


#72 QR_Freez

QR_Freez

    Новосел

  • Житель
  • 90 сообщений

Отправлено 01.03.2008, 23:29

Debian GNU/Linux 4.0-r2 мож кто-нить запишет?

#73 Кот Баюн

Кот Баюн

    активен

  • Небожитель
  • PipPipPipPipPipPip
  • 10 444 сообщений

Отправлено 04.03.2008, 23:25

10 шагов на пути к популярности Linux

04.03.2008 15:58

Мэт Хартли в своей статье «Ten Steps Needed for Fiery Desktop Linux Adoption» рассматривает факторы, которые, по его мнению, мешают широкому распространению Linux и предлагает возможные решения. Ниже краткий перевод статьи.

Каждый месяц появляются статьи, авторы которых утверждают, что они нашли магическую формулу роста популярности Linux на десктопах. Но для меня такие статьи выглядят как попытка поставить телегу перед кобылой. Те, кто заинтересован в настольном Linux пытаются продавать то, что имеет серьезные проблемы. Настольный Linux готов для повседневного использования, но есть области, на которые следует обратить внимание прежде чем говорить о массовом применении. Далее я привожу список тех областей, которые, как я считаю, остро нуждаются во внимании. Хочу сразу предупредить, что я давний пользователь Linux, а не предвзятый гуру Windows.

Дистрибутивы. Существует два противоположных вида дистрибутивов и ни один из них не подходит для повседневного использования. Отличный пример — Debian и Ubuntu. Установив Debian, пользователь получает готовую к использованию, стабильную операционную систему. Оборотной стороной является то, что многие передовые технологии, которые появляются в других Linux-дистрибутивах или даже в OS X/Windows долгое время недоступны в Debian, оставляя пользователя за чертой технологических улучшений. Конечно, можно подключить нестабильный репозиторий, но этот способ не годится для большинства пользователей.

Другое дело Ubuntu. Изменения вносятся часто и всегда полны ошибок, которые объявляются как 'non-critical'. Пользователь Ubuntu часто устанавливает обновления, которые сбивают то одни настройки, то другие. Ubuntu — это фантастический пример прогресса, но, за исключением LTS-релизов, дистрибутив ужасно непродуманный и полный ошибок.

Решения: Для любого вида дистрибутива требуется соблюдать баланс между релизами. Новичок, который начнет знакомство с Linux с дистрибутива, полного ошибок вернется на прежнюю ОС.

Беспроводные адаптеры. Почти каждый поставщик беспроводных устройств игнорирует Linux и оправдывается, в основном, низким числом фактических пользователей, когда разработка модулей для каждого дистрибутива становится нецелесообразной. Тут можно поспорить, ведь, в отличии от проприетарных операционных систем, число пользователей установить очень трудно, ПО распространяется с большого числа зеркал по всему миру.

Я всегда с удивлением наблюдаю, как разработчики и пользователи тратят массу времени, пытаясь заставить работать такие 'hack-n-wish' решения, как NDISWrapper, который использует Windows-драйвера.

Решения: Я думаю, что Linux нуждается в создании центра из существующих компаний, которые поддерживают open source драйвера изначально. Должен быть создан реестр поставщиков, предлагающих беспроводные устройства, которые будут работать с Linux «из коробки».

Устройства все-в-одном. Проблема в том, что пока одно конкретное устройство отлично работает под Linux, 5 других с ним несовместимы. Основываясь на моем собственном опыте, я использую HPLIP, но для тех, кто использует Epson выбор гораздо уже.

Проблема не только в том, что совместимость существует только для ограниченного числа брендов, но и в том, что драйвера редко поставляются на установочном CD. Я уверен, что решения вроде HPLIP должны быть обязательно сразу доступны для новых пользователей. Неправильно заставлять их искать в Google информацию о том, как сделать их устройства рабочими в Linux.

Решения: Несмотря на героические усилия HP в этом направлении, факт остается в том, что другие производители (особенно Lexmark и Epson) тоже должны заняться драйверами под Linux. Пока ситуация не изменится, бесплатный Linux будет иметь цену, ведь новый пользователь вынужден будет пойти и купить новое устройство все-в-одном и только для того, чтобы оно заработало под Linux.

Принтеры и сканеры. В отличии от устройств все-в-одном, я обнаружил, что принтеры хорошо поддерживаются большинством дистрибутивов. Но этого нельзя сказать о сканерах. Даже когда мы говорим о SANE, существует целый ряд моделей, которые не работают так, как ожидалось. Что касается приложений для сканирования, то мой gnomescan никогда не работал так, как от него ожидалось. Однако, Kooka справлялась с задачей. К сожалению, мой старый сканер Canon потребовал дополнительных действий.

Решения: Поставщики вроде Canon должны предоставлять более качественную информацию разработчикам проекта SANE. Потому, что когда модели вроде V500 не появляются в списке совместимости SANE, производитель теряет клиента.

EVDO-доступ без головной боли. Заставить работать EVDO в Linux еще труднее, чем WiFi. Запусти modprobe здесь, отредактируй conf там... Даже после всего этого никаких гарантий. Еще хуже, что вам все равно понадобится Windows, чтобы активировать многие из этих карт.

Решения: Необходимо чтобы операторы проснулись и начали работать и с Linux-клиентами. Просьба активировать карту только под Windows действительно непростительна. Для этого просто нет причин.

Поддержка BlackBerry. Хотя PocketPC и iPhone уже достаточно хорошо поддерживаются в Linux, для BlackBerry ситуация иная.

Решения: Мне бы хотелось, чтобы компания Research In Motion (RIM), разработчик BlackBerry, занялась поддержкой и Linux-пользователей, ведь это та область, в которой RIM может выгодно противопоставить себя остальным участникам мобильного рынка.

Поддержка мобильных телефонов. Современные мобильные телефоны имеют проблему синхронизации контактов с вашим ПК с Linux. Конечно, разработаны приложения для синхронизации под Linux, но все они обладают недостаточной функциональностью и бедным интерфейсом.

Решения: Под усиленной разработкой, я думаю, такие свободные программы, как Conduit имеют все шансы стать чем-то, что можно использовать. Производители мобильных телефонов должны помогать разработчикам ПО.

Отношение к свободным аудио и видеоформатам. Меня поражает, как большинство Linux-пользователей предпочитают использовать MP3. Эти пользователи должны понять, что для того, чтобы Linux получил широкое распространение, мы должны использовать медиаформаты с открытым исходным кодом. Можно использовать контейнер OGG и кодек Vorbis для аудио и Theora/Dirac для видео. Но здесь есть ряд серьезных препятствий. Большинство людей заинтересованы в доступности контента, а не в технологии его воспроизведения. Музыкальная и киноиндустрия хорошо об этом знают. Это позволяет им продвигать несвободные форматы со средствами DRM.

Решения: Я считаю, что это одна из наиболее серьезных проблем. Потому, что разработчики не имеют контроля над медиарынком. Лучшее, что мы можем сделать — рекомендовать пользователям Linux конвертировать их CD в свободные форматы, когда это юридически разрешено. Нам остается надеяться, что когда-нибудь количество пользователей свободных форматов станет достаточным, чтобы на них обратила внимание звукозаписывающая индустрия.

DVD и Blu-Ray. Для воспроизведения DVD используется библиотека libdvdcss, которую DMCA ставит вне закона. Поэтому библиотека отсутствует во многих дистрибутивах и пользователь должен самостоятельно ее скачать и установить.

Решения: Нужно либо доказать законность libdvdcss в суде, либо использовать легальные коммерческие программы просмотра. Что касается Blu-Ray, то мы должны убедиться, что ситуация не повторится.

OEM-производители. За исключением Dell, другие компании занимаются поставками ПК с предустановленным Linux столь малое время, что их трудно назвать реальными игроками на рынке. В прошлом, такие компании, как Linspire, Xandros и другие, пытались проникнуть на рынок Linux через OEM-партнерство, но кроме Xandros с их партнерскими отношениями с ASUS, большинство из этих попыток не увенчалось успехом.

Решения: Dell и есть решение. Несмотря на мое плохое отношения к Dell из-за их выбора Ubuntu, я считаю, что они будут, в конечном итоге, лидерами среди поставщиков Linux для конечного пользователя и докажут, что настольный Linux — это та сила, с которой необходимо считаться. Другие поставщики настольного Linux сохранят свою нишу, но конкурировать с Dell им будет все труднее.



Главная ссылка к новости: http://itmanagement....cle.php/3731586
Перевод: http://www.opennet.r...shtml?num=14534

Сообщение отредактировал iZEN: 04.03.2008, 23:28


„Именно в интуиции нам является сущность бытия как мировая воля, как единое метафизическое начало мира, которое раскрывает себя в многообразии случайных проявлений“

#74 Elliath

Elliath

    Аксакал

  • Почетный житель
  • PipPipPipPip
  • 1 846 сообщений

Отправлено 05.03.2008, 16:36

Ndiswrapper у меня кстати через 4 минуты после сборки заработал.

DVD и Blu-Ray. Для воспроизведения DVD используется библиотека libdvdcss, которую DMCA ставит вне закона. Поэтому библиотека отсутствует во многих дистрибутивах и пользователь должен самостоятельно ее скачать и установить.


Если я не ошибаюсь, существует проприетарный платный LinDVD, который полностью легален.

Сообщение отредактировал INSTE: 05.03.2008, 16:38


#75 R@iden14

R@iden14

    Почетный житель

  • Почетный житель
  • 504 сообщений

Отправлено 06.03.2008, 07:48

Я бы ко всему этому добавил не совсем правильную установку программ, которая мало того, что отличается в разных дистрибутивах, так еще и достаточно сложна для понимания начинающим пользователем. Есть конечно универсальные способы, но они требуют работы в консоли, что по правде сказать начинающему пользователю хуже смерти. Опять же зависимости. Это не правильно, когда в дистрибутивы, основанные на одинаковых форматах пакетов, нельзя установить пакеты друг от друга. Пример тому: fedora, mandriva и opensuse.
Пароль должен быть сложным, но коротким. Чтобы паяльник не успел нагреться.(bash.org.ru)

#76 Zerocul

Zerocul

    на все кнопки мастер

  • Модератор
  • 9 776 сообщений

Отправлено 06.03.2008, 09:28

mandriva и opensuse

Совместимость в этих системах почти 50%. Сам иногда тырю пакеты с мандривы LCE. Большинство установились и стабильно работают. Из АСП'a тоже очень много пакетов ставится
В черном-черном лесу, на берегу черного-черного озера, на черной-черной полянке сидел черный-черный человек и жег автомобильные покрышки

Воинствующий пешеход на K2 Le Mans 80 / GT Avalanche ELITE / K2 F.I.T. Ice


#77 R@iden14

R@iden14

    Почетный житель

  • Почетный житель
  • 504 сообщений

Отправлено 06.03.2008, 09:57

Совместимость в этих системах почти 50%. Сам иногда тырю пакеты с мандривы LCE. Большинство установились и стабильно работают. Из АСП'a тоже очень много пакетов ставится

Но опять же не все, была бы совместимость 100%... Ты их пересобираешь под свою систему? Если да, то опреция опять не совсем тривиальная для начинающего пользователя
Пароль должен быть сложным, но коротким. Чтобы паяльник не успел нагреться.(bash.org.ru)

#78 Zerocul

Zerocul

    на все кнопки мастер

  • Модератор
  • 9 776 сообщений

Отправлено 06.03.2008, 10:13

Ты их пересобираешь под свою систему?

Нет, зачем пересобирать. Проще скачать. Я так трафик экономлю :)
В черном-черном лесу, на берегу черного-черного озера, на черной-черной полянке сидел черный-черный человек и жег автомобильные покрышки

Воинствующий пешеход на K2 Le Mans 80 / GT Avalanche ELITE / K2 F.I.T. Ice


#79 DevoureR

DevoureR

    Black Hack

  • Житель
  • 421 сообщений

Отправлено 18.04.2008, 17:48

ни у каго Mops 6.0 нету?
BrutalDeathGrindSlamTXDM&PornoGore

#80 Zerocul

Zerocul

    на все кнопки мастер

  • Модератор
  • 9 776 сообщений

Отправлено 18.04.2008, 18:10

Есть разумеется.
В черном-черном лесу, на берегу черного-черного озера, на черной-черной полянке сидел черный-черный человек и жег автомобильные покрышки

Воинствующий пешеход на K2 Le Mans 80 / GT Avalanche ELITE / K2 F.I.T. Ice





Количество пользователей, читающих эту тему: 2

0 пользователей, 2 гостей, 0 скрытых пользователей